Hi Guys!
Final blog post for tonight I have spent lots of time this weekend working super hard on my study!
So let's check out FCoE NPV, first a quick word of advice: Make sure when switching fibre channel modes (NPV vs FC Switching) make sure you completely write erase before you switch modes.
Without further adue, let's look at the config!
First thing's first, let's turn on the FCoE NPV Feature on the switch that is going to be on the actual switch performing NPV:
feature fcoe-npv
On the FC switch that will act as our core and WILL participate in the FC as a FC Forwarder, we need to turn on NPIV
feature npiv
As usual with FCoE, let's create our VSAN's and our VLAN's
vsan database
vsan 10
!
vlan 10
fcoe vsan 10
!
Next, we configure our ethernet interface that faces up towards the core, we can do this on both our core switch and our NPV Switch
interface Ethernet1/10
switchport mode trunk
switchport trunk allowed vlan 10,20
!
Next, let's configure our VFC Interface:
interface vfc1
bind interface Ethernet1/10
switchport mode NP
switchport trunk mode on
no shutdown
This is now ready on our NPV side, on our Core switch the config is only slightly diffirent:
interface vfc1
bind interface Ethernet1/10
switchport trunk allowed vsan 10
no shutdown
As you can see on the upstream switch our core switch just has this configured as an F Port.
Now finally, we need to make each of them realise that the port is a member of the VSAN:
vsan database
vsan 10 interface vfc1
Now we can check to see if the vfc interface is up on our NPV Switch:
switch# show int vfc1
vfc1 is trunking (Not all VSANs UP on the trunk)
Bound interface is Ethernet1/10
Hardware is Ethernet
Port WWN is 20:00:54:7f:ee:af:1c:bf
Admin port mode is NP, trunk mode is on
snmp link state traps are enabled
Port mode is TNP
Port vsan is 10
Trunk vsans (admin allowed and active) (1,10)
Trunk vsans (up) (10)
Success! the next step is to get our server facing interface going, for the sake of brevity i will show all the configuration for this at once:
switch# show run int vfc2
interface vfc2
bind interface Ethernet1/1
switchport trunk mode on
no shutdown
!
interface Ethernet1/1
switchport mode trunk
switchport trunk allowed vlan 10,20
spanning-tree port type edge trunk
!
vsan database
vsan 10 interface vfc2
Let's check the server facing interface:
switch# show int vfc2
vfc2 is trunking (Not all VSANs UP on the trunk)
Bound interface is Ethernet1/1
Hardware is Ethernet
Port WWN is 20:01:54:7f:ee:af:1c:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 10
Trunk vsans (admin allowed and active) (1,10)
Trunk vsans (up) (10)
!
Success! Let's check the NPV flogi table which is very useful.
switch# show npv flogi-table
--------------------------------------------------------------------------------
SERVER EXTERNAL INTERFACE VSAN FCID PORT NAME NODE NAME INTERFACE
--------------------------------------------------------------------------------
vfc2 10 0xd80002 20:00:a4:4c:11:13:8c:d1 10:00:a4:4c:11:13:8c:d1 vfc1
Very Useful output showing us that the port vfc2 is logged in and is using vfc1 for its external interface.
The show npv command is actually quite powerful:
switch# show npv ?
external-interface-usage Show external interface usage by server interfaces
flogi-table Show information about FLOGI sessions
internal Show internal NPV information
status Show NPV status
traffic-map Show information about Traffic Map
In particular, i found the following command VERY helpful:
in parti
switch# show npv internal events
1) Event:E_DEBUG, length:94, at 270505 usecs after Sun Apr 21 10:39:22 2013
[538976288] E(10,vfc1) Received GMAL Response from core switch with Core Switch Inet Addr: 10.1.1.15
2) Event:E_DEBUG, length:252, at 270497 usecs after Sun Apr 21 10:39:22 2013
[538976288] E(10,vfc1) npivp_get_ext_intf_fsm(1466): Is Core VF Capable: TRU
E, Is Phy Login Done: TRUE, Is Port Channel: FALSE RID: { Type: Ext-If-VSAN(8),
IfIndex: vfc1(0x1e000000), UCD: 0, VSAN: 10, PWWN: 00:00:00:00:00:00:00:00 }, St
ate NPIVP_EXT_IF_ST_UP
This, along with show npv internal errors is really helpful in troubleshooting upstream issues.
If for example the upstream switch was not enabled for NPIV, I would see the following output in this command:
11) Event:E_DEBUG, length:98, at 464269 usecs after Sun Apr 21 10:41:22 2013
[112] E(10,vfc1) FC Upstream switch is not NPIV enabled. Bringing down the external interface: vfc1
Subscribe to:
Post Comments (Atom)
Popular old posts.
-
Hi Guys Having spent a lot of time with customers working on vPC deployments, I have found quite a few of the gotcha's for vPC that I w...
-
Hi Guys! This blog post is attempting to be the DEFINITIVE guide on Jumbo MTU, It's a topic that DOES MY HEAD IN! There are SO many ...
-
So some of the readers of this blog might already know this little trick, and what's more some of you might be surprised I didn't kn...
These posts are awesome - keep them coming :)
ReplyDeletehi Peter, I have a question related to NPV, in the CCIE DC lab, we need to enable NPV mode in N5k after doing many config with N5k. It need to be reloaded, so how we deal with this one in the practical CCIE DC Exam?
ReplyDeleteWhen you enable the FCoE NPV using the feature "fcoe-npv" command, a write erase reload does not occur. Unlike, enabling "FCoE" and then "NPV" as separate features.
DeleteYep, true, you don't have to reload the switch after configuring "feature fcoe-npv"... However, if you are coming from a FCoE configuration where you previously had the switch with "feature fcoe", you have to first remove the feature "no feature fcoe" and then RELOAD!
DeleteI've tested it myself. I tried to only delete the FCoE config: vfcs, fcoe vlan, the actual vsan and then removed "feature fcoe", then enabled "feature fcoe-npv" without reloading. I then entered again all the FCoE required config for NPV, but there my NP port never came up. I double-checked all the config, reentered it, but nothing, I then removed the feature fcoe, reloaded and then enter the exact same config I had entered before for fcoe-npv and NOW the NP port came up.
Why? I have no idea, but it will save you a lot of time if you just reload the switch after removing feature fcoe.
hi
ReplyDeletewhat if their is already a config on the switch if i enable NPIV and those ports are connected to HP VC it will erase the config on cisco so how can i restore zoning config
"show npv status" is also a great troubleshooting command. Many times it tells you exactly what's wrong. Here's the troubleshooting guide for NPV:
ReplyDeletehttp://www.cisco.com/en/US/products/ps5989/prod_troubleshooting_guide_chapter09186a00808c82f1.html
"show int vfc1" and "show int vfc1 trunk vsan" are always a great help.